Authentication service maintenance
Scheduled for October 19, 2025 at 11:00 AM – 1:00 PM
Affects
Tela UI
Under maintenance from 11:00 AM to 12:00 AM
Update
October 19, 2025 at 1:09 PMIn progress
October 19, 2025 at 1:09 PMThe maintenance is taking longer than expected. We’ll continue to update this page as new information becomes available.
In progress
October 19, 2025 at 11:00 AMIn progress
October 19, 2025 at 11:00 AMMaintenance is now in progress
Planned
October 19, 2025 at 11:00 AMPlanned
October 19, 2025 at 11:00 AMWe are planning for a scheduled maintenance during that time.